Проблемы с блокировкой с помощью «apt -y update && apt -y install python» в Ubuntu 18.04.1 LTS


0

Я создаю Ansible Playbook для настройки VPS Ubuntu 18.04.1 и сталкиваюсь с проблемой, когда не могу надежно установить Python.

Поскольку Ubuntu 18.04.1 не поставляется с установленным Python, я вынужден использовать следующую команду apt -y update && apt -y install pythonс rawмодулем.

Мне также удалось получить эту ошибку в оболочке, в которую я вручную вставил ssh'd.

[email protected]:~# apt -y update && apt -y install python
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
17 packages can be upgraded. Run 'apt list --upgradable' to see them.
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Это виртуальная машина в VirtualBox на хосте Windows.

Я также пытался использовать syncмежду apt updateи apt installдаже делать что-то подобное while fuser /var/lib/dpkg/lock >/dev/null 2>&1; do sync && sleep 1; doneмежду updateи install, но обычно это не получается.

Это система, которая была настроена с помощью следующих шагов: https://askubuntu.com/questions/946787/ubuntu-server-installation-with-root-only/1066033#1066033

Ответы:


0

Ubuntu 16.04+, iirc, поставляется с Python3 по умолчанию и полностью удалил Python2 из установки по умолчанию; другими словами, есть работающий интерпретатор Python, он просто не в том месте, где выглядит Ansible.

Вы можете переопределить поведение по умолчанию (ожидая pythonв качестве команды), используя ansible_python_interpreterпеременную и установив ее в случае с Ubuntu 16.04+ /usr/bin/python3.

Так что-то вроде этого: ansible_python_interpreter: /usr/bin/python3

Ansible теперь рассматривает Python3 как первоклассного гражданина по большей части, так что это довольно безопасное изменение. Я использовал его на нескольких блоках Ubuntu 18.04, которые я администрирую без проблем.

Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.