“Conectar: ​​a rede está inacessível” em uma interface wlan0 funcionando (conectada)


36

Finalmente consegui conectar o wlan0 (um dongle USB WiFi Edimax EW-7811Un) ao meu roteador, mas depois apt-get updatedescobri que o Raspberry não pode ver fora da rede local. O meu Raspberry está sendo executado na imagem Raspbian mais recente (no momento em que foi escrita).

  • wlan0 está conectado ao meu roteador e recebeu um endereço IP
  • Posso executar ping no meu roteador, na minha impressora e em outras máquinas dentro da rede local, mas não consigo executar ping na rede externa (o ping de loopback no localhost diz "host inacessível", mas eu diria que está cancelando o NAT 127.0.0.1 pedidos)
  • Posso me conectar com êxito eth0, mas preciso me conectar wlan0.

saída ifconfig:

[email protected] ~ $ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr *macaddresshere*
      inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:552 errors:0 dropped:6 overruns:0 frame:0
      TX packets:289 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:375003 (366.2 KiB)  TX bytes:318051 (310.5 KiB)

Saída do iwconfig:

[email protected] ~ $ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"Sanctuary"  Nickname:"<[email protected]>"
      Mode:Managed  Frequency:2.437 GHz  Access Point: *macaddresshere*
      Bit Rate:54 Mb/s   Sensitivity:0/0
      Retry:off   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=100/100  Signal level=100/100  Noise level=0/100
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

/etc/network/interfaces Arquivo:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

iface wlan0 inet static
    address 192.168.1.9
    netmask 255.255.255.0
    gateway 192.168.1.1
    wpa-ssid "Sanctuary"
    wpa-psk "somePasswordHere"

Alguma ideia?

Respostas:


59

Problema resolvido! Parece que, embora eu tenha adicionado as informações do gateway no arquivo de interfaces, wlan0realmente não tinha um gateway padrão.

Quando eu corri

sudo route -n

rendeu

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0

Lá está - não há IP do gateway. Eu digitei isso:

 sudo route add default gw 192.168.1.1

(em que 192.168.1.1 é um endereço IP do meu roteador, conectado à rede externa)

Et voilà: funciona.


4
Alguém tem alguma idéia de por que o gateway não está sendo adicionado automaticamente?
Endareth

Você deve adicionar o IP do seu roteador, não o IP da sua máquina.
Błażej Michalik 03/04

3
@ Błażej Michalik, estou usando o sistema operacional Raspberry PI 3. O problema está em mascarar o endereço IP do gateway e * persistir * durante as reinicializações. Como você proporia mascarar o endereço IP do gateway e * persistir * durante as reinicializações? Obrigado #
1948

O IP do @Frank Gateway não está mascarado, é apenas um endereço, não é um intervalo de endereços. Você precisa adicionar uma rota de gateway às suas tabelas de roteamento. O mascaramento dos endereços de destino é da sua configuração de rede local. O utilitário de rota deve adicionar o endereço de maneira persistente, mas acho que está depreciado agora, você pode procurar ip route( man ip).
Błażej Michalik

1
Estou muito interessado na resposta à pergunta @Endareth - ainda mais em como codificar uma resposta para que o raspberry pi encontre e conecte-se a uma resposta automaticamente. Se você der um raspberry pi de presente a alguém que não conhece computadores, ele não deve parar de funcionar imediatamente.
chase
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.